aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/init_usrp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/examples/init_usrp/CMakeLists.txt')
-rw-r--r--host/examples/init_usrp/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/host/examples/init_usrp/CMakeLists.txt b/host/examples/init_usrp/CMakeLists.txt
new file mode 100644
index 000000000..8cfea0a32
--- /dev/null
+++ b/host/examples/init_usrp/CMakeLists.txt
@@ -0,0 +1,46 @@
+#
+# Copyright 2014 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+cmake_minimum_required(VERSION 2.8)
+
+### Set up build environment ##################################################
+# This example also requires Boost:
+set(BOOST_REQUIRED_COMPONENTS
+ program_options
+ system
+ thread
+)
+find_package(Boost "1.35" REQUIRED ${BOOST_REQUIRED_COMPONENTS})
+
+# To add UHD as a dependency to this project, add a line such as this:
+find_package(UHD "3.7.1" REQUIRED)
+# The version in ^^^^^ here is a minimum version.
+# To specify an exact version:
+#find_package(UHD 3.7.1 EXACT REQUIRED)
+
+### Configure Compiler ########################################################
+include_directories(
+ ${Boost_INCLUDE_DIRS}
+ ${UHD_INCLUDE_DIRS}
+)
+
+### Make the executable #######################################################
+add_executable(init_usrp init_usrp.cpp)
+target_link_libraries(init_usrp ${UHD_LIBRARIES} ${Boost_LIBRARIES})
+
+# Here, you would have commands to install your program.
+# We will skip these in this example.