aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index c3bbbcd04..fea6cb98f 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -22,9 +22,15 @@ TARGET_LINK_LIBRARIES(benchmark_rx_rate uhd)
ADD_EXECUTABLE(rx_timed_samples rx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(rx_timed_samples uhd)
+ADD_EXECUTABLE(rx_to_file rx_to_file.cpp)
+TARGET_LINK_LIBRARIES(rx_to_file uhd)
+
ADD_EXECUTABLE(tx_timed_samples tx_timed_samples.cpp)
TARGET_LINK_LIBRARIES(tx_timed_samples uhd)
+ADD_EXECUTABLE(tx_from_file tx_from_file.cpp)
+TARGET_LINK_LIBRARIES(tx_from_file uhd)
+
ADD_EXECUTABLE(tx_waveforms tx_waveforms.cpp)
TARGET_LINK_LIBRARIES(tx_waveforms uhd)
@@ -32,6 +38,8 @@ INSTALL(TARGETS
benchmark_rx_rate
rx_timed_samples
tx_timed_samples
+ tx_from_file
+ rx_to_file
tx_waveforms
RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
)