aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt69
1 files changed, 69 insertions, 0 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
new file mode 100644
index 000000000..3203cffc0
--- /dev/null
+++ b/host/examples/CMakeLists.txt
@@ -0,0 +1,69 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+ADD_EXECUTABLE(benchmark_rx_rate benchmark_rx_rate.cpp)
+TARGET_LINK_LIBRARIES(benchmark_rx_rate uhd)
+
+ADD_EXECUTABLE(rx_timed_samples rx_timed_samples.cpp)
+TARGET_LINK_LIBRARIES(rx_timed_samples uhd)
+
+ADD_EXECUTABLE(rx_to_file rx_to_file.cpp)
+TARGET_LINK_LIBRARIES(rx_to_file uhd)
+
+ADD_EXECUTABLE(rx_to_udp rx_to_udp.cpp)
+TARGET_LINK_LIBRARIES(rx_to_udp uhd)
+
+ADD_EXECUTABLE(test_async_messages test_async_messages.cpp)
+TARGET_LINK_LIBRARIES(test_async_messages uhd)
+
+ADD_EXECUTABLE(test_pps_input test_pps_input.cpp)
+TARGET_LINK_LIBRARIES(test_pps_input uhd)
+
+ADD_EXECUTABLE(tx_timed_samples tx_timed_samples.cpp)
+TARGET_LINK_LIBRARIES(tx_timed_samples uhd)
+
+ADD_EXECUTABLE(tx_from_file tx_from_file.cpp)
+TARGET_LINK_LIBRARIES(tx_from_file uhd)
+
+ADD_EXECUTABLE(tx_waveforms tx_waveforms.cpp)
+TARGET_LINK_LIBRARIES(tx_waveforms uhd)
+
+INSTALL(TARGETS
+ benchmark_rx_rate
+ rx_timed_samples
+ test_async_messages
+ test_pps_input
+ tx_timed_samples
+ tx_from_file
+ rx_to_file
+ rx_to_udp
+ tx_waveforms
+ RUNTIME DESTINATION ${PKG_DATA_DIR}/examples
+)
+
+########################################################################
+# ASCII Art DFT - requires curses, so this part is optional
+########################################################################
+INCLUDE(FindCurses)
+
+IF(CURSES_FOUND)
+ INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
+ ADD_EXECUTABLE(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+ TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES})
+ INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_DATA_DIR}/examples)
+ENDIF(CURSES_FOUND)