aboutsummaryrefslogtreecommitdiffstats
path: root/host/docs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/docs/CMakeLists.txt')
-rw-r--r--host/docs/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/host/docs/CMakeLists.txt b/host/docs/CMakeLists.txt
index 7f510f58c..a702f76c6 100644
--- a/host/docs/CMakeLists.txt
+++ b/host/docs/CMakeLists.txt
@@ -66,6 +66,7 @@ ENDIF(ENABLE_MANUAL)
LIBUHD_REGISTER_COMPONENT("API/Doxygen" ENABLE_DOXYGEN ON "DOXYGEN_FOUND" OFF OFF)
OPTION(ENABLE_DOXYGEN_FULL "Use Doxygen to document the entire source tree (not just API)" OFF)
OPTION(ENABLE_DOXYGEN_DOT "Let Doxygen use dot (requires graphviz)" OFF)
+OPTION(ENABLE_DOXYGEN_SHORTNAMES "Let Doxygen use shorter filenames (helps on Windows)" OFF)
IF(LIBUHDDEV_PKG)
SET(PKG_DOC_DIR share/doc/libuhd-dev)
@@ -98,6 +99,11 @@ IF(ENABLE_MANUAL_OR_DOXYGEN)
ELSE(ENABLE_DOXYGEN_DOT)
SET(DOXYGEN_HAVE_DOT "NO")
ENDIF(ENABLE_DOXYGEN_DOT)
+ IF(ENABLE_DOXYGEN_SHORTNAMES)
+ SET(DOXYGEN_SHORT_NAMES "YES")
+ ELSE(ENABLE_DOXYGEN_SHORTNAMES)
+ SET(DOXYGEN_SHORT_NAMES "NO")
+ ENDIF(ENABLE_DOXYGEN_SHORTNAMES)
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in