aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index d0c576ee5..e64c1031f 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -65,8 +65,6 @@ ENDIF(NOT CMAKE_BUILD_TYPE)
IF(CMAKE_COMPILER_IS_GNUCXX)
ADD_DEFINITIONS(-Wall)
ADD_DEFINITIONS(-Wextra)
- #causes trouble when compiling libusb1.0 on macintosh
- #comment out until mac ports libusb gets its act together
#ADD_DEFINITIONS(-pedantic)
#ADD_DEFINITIONS(-ansi)
#only export symbols that are declared to be part of the uhd api:
@@ -79,7 +77,6 @@ IF(MSVC)
ADD_DEFINITIONS(-DNOMINMAX) #disables stupidity and enables std::min and std::max
ADD_DEFINITIONS(-D_SCL_SECURE_NO_WARNINGS) #avoid warnings from boost::split
ADD_DEFINITIONS(-DBOOST_ALL_DYN_LINK) #setup boost auto-linking in msvc
- ADD_DEFINITIONS(/arch:SSE2 /G7) #processor optimization flags
ENDIF(MSVC)
########################################################################