aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt34
1 files changed, 32 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index c235ffe82..5ae2a3273 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -166,6 +166,22 @@ IF(MSVC)
ADD_DEFINITIONS(/MP) #multi-threaded build
ENDIF(MSVC)
+IF(MINGW)
+ #Avoid depending on MinGW runtime DLLs
+ CHECK_CXX_COMPILER_FLAG(-static-libgcc HAVE_STATIC_LIBGCC_FLAG)
+ IF(HAVE_STATIC_LIBGCC_FLAG)
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -static-libgcc")
+ SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -static-libgcc")
+ SET(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -static-libgcc")
+ ENDIF()
+ CHECK_CXX_COMPILER_FLAG(-static-libstdc++ HAVE_STATIC_LIBSTDCXX_FLAG)
+ IF(HAVE_STATIC_LIBSTDCXX_FLAG)
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -static-libstdc++")
+ SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -static-libstdc++")
+ SET(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -static-libstdc++")
+ ENDIF()
+ENDIF()
+
IF(CYGWIN)
ADD_DEFINITIONS(-D__USE_W32_SOCKETS) #boost asio says we need this
ENDIF(CYGWIN)
@@ -268,8 +284,8 @@ UHD_INSTALL(FILES
#{{{IMG_SECTION
# This section is written automatically by /images/create_imgs_package.py
# Any manual changes in here will be overwritten.
-SET(UHD_IMAGES_MD5SUM "57c06338de0504f296a2431762725683")
-SET(UHD_IMAGES_DOWNLOAD_SRC "uhd-images_003.008.003-release.zip")
+SET(UHD_IMAGES_MD5SUM "37d4899e320809951149c3670fb054ee")
+SET(UHD_IMAGES_DOWNLOAD_SRC "uhd-images_003.009.git-139-g3e3e236a.zip")
#}}}
########################################################################
@@ -420,5 +436,19 @@ ELSEIF(UHDHOST_PKG)
SET(PRINT_APPEND " (Debian uhd-host package configuration)")
ENDIF(LIBUHD_PKG)
UHD_PRINT_COMPONENT_SUMMARY()
+IF(UHD_VERSION_DEVEL)
+ MESSAGE(STATUS "******************************************************")
+ IF(UHD_VERSION_PATCH STREQUAL "git")
+ MESSAGE(STATUS "* You are building the UHD development master branch.")
+ MESSAGE(STATUS "* For production code, we recommend our stable,")
+ MESSAGE(STATUS "* releases or using the release branch (maint).")
+ ELSE()
+ MESSAGE(STATUS "* You are building a development branch of UHD.")
+ MESSAGE(STATUS "* These branches are designed to provide early access")
+ MESSAGE(STATUS "* to UHD and USRP features, but should be considered")
+ MESSAGE(STATUS "* unstable and/or experimental!")
+ ENDIF(UHD_VERSION_PATCH STREQUAL "git")
+ MESSAGE(STATUS "******************************************************")
+ENDIF(UHD_VERSION_DEVEL)
MESSAGE(STATUS "Building version: ${UHD_VERSION}${PRINT_APPEND}")
MESSAGE(STATUS "Using install prefix: ${CMAKE_INSTALL_PREFIX}")