summaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 57670fa6e..a8b89d6c5 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -16,7 +16,7 @@
#
CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-PROJECT(UHD)
+PROJECT(UHD CXX)
ENABLE_TESTING()
########################################################################
@@ -90,15 +90,6 @@ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
########################################################################
-# Setup Endianess
-########################################################################
-INCLUDE(TestBigEndian)
-TEST_BIG_ENDIAN(HAVE_BIG_ENDIAN)
-IF(HAVE_BIG_ENDIAN)
- ADD_DEFINITIONS(-DHAVE_BIG_ENDIAN)
-ENDIF(HAVE_BIG_ENDIAN)
-
-########################################################################
# Create Uninstall Target
########################################################################
CONFIGURE_FILE(