aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/zpu/usrp2p/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/zpu/usrp2p/CMakeLists.txt')
-rw-r--r--firmware/zpu/usrp2p/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/firmware/zpu/usrp2p/CMakeLists.txt b/firmware/zpu/usrp2p/CMakeLists.txt
index f93924bc0..93ccf82c3 100644
--- a/firmware/zpu/usrp2p/CMakeLists.txt
+++ b/firmware/zpu/usrp2p/CMakeLists.txt
@@ -36,14 +36,16 @@ ADD_LIBRARY(libusrp2pfw STATIC
ADD_SUBDIRECTORY(bootloader)
########################################################################
+SET(GEN_OUTPUTS_BIN_SIZE 0x3fff)
+
ADD_EXECUTABLE(usrp2p_txrx_uhd.elf ${CMAKE_SOURCE_DIR}/apps/txrx_uhd.c)
TARGET_LINK_LIBRARIES(usrp2p_txrx_uhd.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_txrx_uhd.elf 0x3fff)
+GEN_OUTPUTS(usrp2p_txrx_uhd.elf)
ADD_EXECUTABLE(usrp2p_blinkenlights.elf ${CMAKE_SOURCE_DIR}/apps/blinkenlights.c)
TARGET_LINK_LIBRARIES(usrp2p_blinkenlights.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_blinkenlights.elf 0x3fff)
+GEN_OUTPUTS(usrp2p_blinkenlights.elf)
ADD_EXECUTABLE(usrp2p_uart_flash_loader.elf ${CMAKE_SOURCE_DIR}/apps/uart_flash_loader.c)
TARGET_LINK_LIBRARIES(usrp2p_uart_flash_loader.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_uart_flash_loader.elf 0x3fff)
+GEN_OUTPUTS(usrp2p_uart_flash_loader.elf)