aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/octoclock/octoclock_r4/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/octoclock/octoclock_r4/CMakeLists.txt')
-rw-r--r--firmware/octoclock/octoclock_r4/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/firmware/octoclock/octoclock_r4/CMakeLists.txt b/firmware/octoclock/octoclock_r4/CMakeLists.txt
index a030d3249..c3559d8d4 100644
--- a/firmware/octoclock/octoclock_r4/CMakeLists.txt
+++ b/firmware/octoclock/octoclock_r4/CMakeLists.txt
@@ -17,6 +17,9 @@
add_executable(octoclock_r4_fw.elf octoclock_r4_main.c)
target_link_libraries(octoclock_r4_fw.elf octoclock)
+set_target_properties(octoclock_r4_fw.elf PROPERTIES
+ LINK_FLAGS "-Wl,--relax,-Map=octoclock_r4_fw.map,--cref"
+)
add_custom_command(
OUTPUT ${CMAKE_BINARY_DIR}/octoclock_r4_fw.bin