aboutsummaryrefslogtreecommitdiffstats
path: root/firmware/microblaze/usrp2p/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/microblaze/usrp2p/CMakeLists.txt')
-rw-r--r--firmware/microblaze/usrp2p/CMakeLists.txt48
1 files changed, 0 insertions, 48 deletions
diff --git a/firmware/microblaze/usrp2p/CMakeLists.txt b/firmware/microblaze/usrp2p/CMakeLists.txt
deleted file mode 100644
index 41ef8f1dd..000000000
--- a/firmware/microblaze/usrp2p/CMakeLists.txt
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright 2010 Ettus Research LLC
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-
-########################################################################
-INCLUDE(${CMAKE_SOURCE_DIR}/lib/CMakeLists.txt)
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
-
-ADD_DEFINITIONS(-DUSRP2P)
-
-ADD_LIBRARY(libusrp2pfw STATIC
- ${COMMON_SRCS}
- spif.c
- spi_flash.c
- spi_flash_read.c
- bootloader_utils.c
- ethernet.c
- xilinx_s3_icap.c
- udp_fw_update.c
-)
-
-ADD_SUBDIRECTORY(bootloader)
-
-########################################################################
-ADD_EXECUTABLE(usrp2p_txrx_uhd.elf ${CMAKE_SOURCE_DIR}/apps/txrx_uhd.c)
-TARGET_LINK_LIBRARIES(usrp2p_txrx_uhd.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_txrx_uhd.elf)
-
-ADD_EXECUTABLE(usrp2p_blinkenlights.elf ${CMAKE_SOURCE_DIR}/apps/blinkenlights.c)
-TARGET_LINK_LIBRARIES(usrp2p_blinkenlights.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_blinkenlights.elf)
-
-ADD_EXECUTABLE(usrp2p_uart_flash_loader.elf ${CMAKE_SOURCE_DIR}/apps/uart_flash_loader.c)
-TARGET_LINK_LIBRARIES(usrp2p_uart_flash_loader.elf libusrp2pfw)
-GEN_OUTPUTS(usrp2p_uart_flash_loader.elf)