summaryrefslogtreecommitdiffstats
path: root/firmware/microblaze/usrp2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'firmware/microblaze/usrp2/Makefile.am')
-rw-r--r--firmware/microblaze/usrp2/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/firmware/microblaze/usrp2/Makefile.am b/firmware/microblaze/usrp2/Makefile.am
new file mode 100644
index 000000000..859ded9e5
--- /dev/null
+++ b/firmware/microblaze/usrp2/Makefile.am
@@ -0,0 +1,43 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CFLAGS = \
+ $(COMMON_CFLAGS)
+
+AM_LDFLAGS = \
+ $(COMMON_LFLAGS) \
+ libusrp2.a \
+ -Wl,-defsym -Wl,_TEXT_START_ADDR=0x0050 \
+ -Wl,-defsym -Wl,_STACK_SIZE=3072
+
+########################################################################
+# USRP2 specific library and programs
+########################################################################
+noinst_LIBRARIES = libusrp2.a
+
+libusrp2_a_SOURCES = \
+ $(COMMON_SRCS) \
+ clocks.c \
+ sd.c
+
+noinst_PROGRAMS = \
+ usrp2_txrx_uhd.elf
+
+usrp2_txrx_uhd_elf_SOURCES = \
+ $(top_srcdir)/apps/txrx_uhd.c