summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4fc1e29f9..58254e413 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,10 +18,16 @@
CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
PROJECT(UHD)
ENABLE_TESTING()
-INCLUDE(CPack)
#SET(CMAKE_VERBOSE_MAKEFILE true)
########################################################################
+# Setup CPack
+########################################################################
+SET(CPACK_RESOURCE_FILE_README ${CMAKE_SOURCE_DIR}/README)
+SET(CPACK_RESOURCE_FILE_LICENSE ${CMAKE_SOURCE_DIR}/LICENSE)
+INCLUDE(CPack) #include after setting vars
+
+########################################################################
# Install Dirs
########################################################################
SET(RUNTIME_DIR bin)
@@ -67,7 +73,11 @@ LINK_DIRECTORIES(${Boost_LIBRARY_DIRS})
########################################################################
# Create Pkg Config File
########################################################################
-CONFIGURE_FILE(uhd.pc.in uhd.pc @ONLY)
+CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/uhd.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/uhd.pc
+ @ONLY
+)
INSTALL(
FILES ${CMAKE_CURRENT_BINARY_DIR}/uhd.pc
DESTINATION ${LIBRARY_DIR}/pkgconfig