summaryrefslogtreecommitdiffstats
path: root/usrp_dboard/lib/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-01-08 19:11:58 -0800
committerJosh Blum <josh@joshknows.com>2010-01-08 19:11:58 -0800
commit4e94574aeaa46c671bba0a6fc83cb967d228c880 (patch)
treedbc3ef97a3170875d07d9e0ab510d635c036edd6 /usrp_dboard/lib/Makefile.am
parenta478ffe79757f82ce16b6694d860a53dac60849c (diff)
downloaduhd-4e94574aeaa46c671bba0a6fc83cb967d228c880.tar.gz
uhd-4e94574aeaa46c671bba0a6fc83cb967d228c880.tar.bz2
uhd-4e94574aeaa46c671bba0a6fc83cb967d228c880.zip
Created subcomponent for usrp dboards.
Only populated the interface though.
Diffstat (limited to 'usrp_dboard/lib/Makefile.am')
-rw-r--r--usrp_dboard/lib/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/usrp_dboard/lib/Makefile.am b/usrp_dboard/lib/Makefile.am
new file mode 100644
index 000000000..69f2c8568
--- /dev/null
+++ b/usrp_dboard/lib/Makefile.am
@@ -0,0 +1,23 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+
+include $(top_srcdir)/Makefile.common
+
+SUBDIRS =
+
+AM_CPPFLAGS = \
+ $(USRP_DBOARD_INCLUDES) \
+ $(BOOST_CPPFLAGS)
+
+noinst_LTLIBRARIES = \
+ libusrp_dboard.la
+
+libusrp_dboard_la_SOURCES = \
+ interface.cpp
+
+libusrp_dboard_la_LIBADD = \
+ $(BOOST_LDFLAGS) \
+ $(BOOST_THREAD_LIB)
+
+noinst_HEADERS =