summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-02-15 14:10:41 -0800
committerJosh Blum <josh@joshknows.com>2010-02-15 14:10:41 -0800
commit8d76c9a40859182d601d6f58064ddb7181fb6ce6 (patch)
tree66c3511b00a29be8bb2da376b3e945e3b754723b /test/CMakeLists.txt
parent97785c838e088f978c8dd2c4c796cdcbeafebffc (diff)
downloaduhd-8d76c9a40859182d601d6f58064ddb7181fb6ce6.tar.gz
uhd-8d76c9a40859182d601d6f58064ddb7181fb6ce6.tar.bz2
uhd-8d76c9a40859182d601d6f58064ddb7181fb6ce6.zip
Created CMakeLists.txt for a CMake build.
Only created the files for building, install part missing.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 000000000..0dcd1e68e
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,30 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+
+ADD_EXECUTABLE(main_test
+ main_test.cpp
+ addr_test.cpp
+ device_test.cpp
+ gain_handler_test.cpp
+ usrp_dboard_test.cpp
+ wax_test.cpp
+)
+
+TARGET_LINK_LIBRARIES(main_test uhd)
+
+ADD_TEST(test main_test)