aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2022-01-28 11:53:35 +0100
committerAaron Rossetto <aaron.rossetto@ni.com>2022-02-16 14:52:55 -0600
commit541865b88b0b6f7425bec7a6ade8a99763e92b3f (patch)
treed70c8a4abf5ffff1bbf08475b9325dd50c2aad6c /mpm/tools/CMakeLists.txt
parentfeb2220d81c401bf0b3bda5c4ba089427b0d3865 (diff)
downloaduhd-541865b88b0b6f7425bec7a6ade8a99763e92b3f.tar.gz
uhd-541865b88b0b6f7425bec7a6ade8a99763e92b3f.tar.bz2
uhd-541865b88b0b6f7425bec7a6ade8a99763e92b3f.zip
mpm: cmake: Remove installation of non-relevant EEPROM tools
On N3x0 and E3x0 devices, we were erroneously installing EEPROM utilities that are only relevant on X410.
Diffstat (limited to 'mpm/tools/CMakeLists.txt')
-rw-r--r--mpm/tools/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/mpm/tools/CMakeLists.txt b/mpm/tools/CMakeLists.txt
index c61e4562c..f735c04f3 100644
--- a/mpm/tools/CMakeLists.txt
+++ b/mpm/tools/CMakeLists.txt
@@ -44,4 +44,6 @@ foreach(eeprom_tool_source ${eeprom_tool_sources})
install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/${eeprom_tool} DESTINATION ${RUNTIME_DIR})
endforeach(eeprom_tool_source ${eeprom_tool_sources})
-add_subdirectory(tlv_eeprom)
+if(ENABLE_LIBMPM AND ENABLE_X400)
+ add_subdirectory(tlv_eeprom)
+endif(ENABLE_LIBMPM AND ENABLE_X400)