aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/systemd/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Amsel <lars.amsel@ni.com>2021-06-04 08:27:50 +0200
committerAaron Rossetto <aaron.rossetto@ni.com>2021-06-10 12:01:53 -0500
commit2a575bf9b5a4942f60e979161764b9e942699e1e (patch)
tree2f0535625c30025559ebd7494a4b9e7122550a73 /mpm/systemd/CMakeLists.txt
parente17916220cc955fa219ae37f607626ba88c4afe3 (diff)
downloaduhd-2a575bf9b5a4942f60e979161764b9e942699e1e.tar.gz
uhd-2a575bf9b5a4942f60e979161764b9e942699e1e.tar.bz2
uhd-2a575bf9b5a4942f60e979161764b9e942699e1e.zip
uhd: Add support for the USRP X410
Co-authored-by: Lars Amsel <lars.amsel@ni.com> Co-authored-by: Michael Auchter <michael.auchter@ni.com> Co-authored-by: Martin Braun <martin.braun@ettus.com> Co-authored-by: Paul Butler <paul.butler@ni.com> Co-authored-by: Cristina Fuentes <cristina.fuentes-curiel@ni.com> Co-authored-by: Humberto Jimenez <humberto.jimenez@ni.com> Co-authored-by: Virendra Kakade <virendra.kakade@ni.com> Co-authored-by: Lane Kolbly <lane.kolbly@ni.com> Co-authored-by: Max Köhler <max.koehler@ni.com> Co-authored-by: Andrew Lynch <andrew.lynch@ni.com> Co-authored-by: Grant Meyerhoff <grant.meyerhoff@ni.com> Co-authored-by: Ciro Nishiguchi <ciro.nishiguchi@ni.com> Co-authored-by: Thomas Vogel <thomas.vogel@ni.com>
Diffstat (limited to 'mpm/systemd/CMakeLists.txt')
-rw-r--r--mpm/systemd/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/mpm/systemd/CMakeLists.txt b/mpm/systemd/CMakeLists.txt
index 8387c68cc..bc5b457a5 100644
--- a/mpm/systemd/CMakeLists.txt
+++ b/mpm/systemd/CMakeLists.txt
@@ -27,12 +27,32 @@ install(FILES
DESTINATION ${SYSTEMD_SYSTEM_UNITDIR}
)
+if(MPM_DEVICE STREQUAL "x4xx")
+ set(UHD_SELF_CAL_SERIES "X400")
+ set(UHD_SELF_CAL_ARGS "type=x4xx,addr=169.254.0.2,mgmt_addr=127.0.0.1")
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/system/usrp-adc-self-cal.service.in
+ ${CMAKE_CURRENT_BINARY_DIR}/system/usrp-adc-self-cal.service
+ )
+
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/system/usrp-adc-self-cal.service
+ DESTINATION ${SYSTEMD_SYSTEM_UNITDIR}
+ )
+endif()
+
# network configuration files
install(FILES
${CMAKE_CURRENT_SOURCE_DIR}/network/eth0.network
${CMAKE_CURRENT_SOURCE_DIR}/network/int0.network
${CMAKE_CURRENT_SOURCE_DIR}/network/sfp0.network
+ ${CMAKE_CURRENT_SOURCE_DIR}/network/sfp0_1.network
+ ${CMAKE_CURRENT_SOURCE_DIR}/network/sfp0_2.network
+ ${CMAKE_CURRENT_SOURCE_DIR}/network/sfp0_3.network
${CMAKE_CURRENT_SOURCE_DIR}/network/sfp1.network
+ ${CMAKE_CURRENT_SOURCE_DIR}/network/sfp1_1.network
+ ${CMAKE_CURRENT_SOURCE_DIR}/network/sfp1_2.network
+ ${CMAKE_CURRENT_SOURCE_DIR}/network/sfp1_3.network
DESTINATION ${SYSTEMD_SYSTEM_UNITDIR}/../network
)