aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/python/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-01-24 16:26:03 -0800
committerBrent Stapleton <bstapleton@g.hmc.edu>2018-10-09 17:11:08 -0700
commite5782693cad41b851b37f5f2535221a2f81c6872 (patch)
treeecce225b5594d9a7244a743e2fd6c14546ded33e /mpm/python/CMakeLists.txt
parent6466ae1d3eedec66c8eb1014ceb3ca48d25e72d5 (diff)
downloaduhd-e5782693cad41b851b37f5f2535221a2f81c6872.tar.gz
uhd-e5782693cad41b851b37f5f2535221a2f81c6872.tar.bz2
uhd-e5782693cad41b851b37f5f2535221a2f81c6872.zip
mpm: Add usrp_update_fs
This provides a new utility for MPM devices (usrp_update_fs.py), which goes through all the necessary steps to update a filesystem. Will trigger a mender update, but the tool is not specific to Mender and can be changed to use other methods in the future.
Diffstat (limited to 'mpm/python/CMakeLists.txt')
-rw-r--r--mpm/python/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/mpm/python/CMakeLists.txt b/mpm/python/CMakeLists.txt
index 4b8904600..8218ce915 100644
--- a/mpm/python/CMakeLists.txt
+++ b/mpm/python/CMakeLists.txt
@@ -50,6 +50,7 @@ EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c
INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/build/lib/usrp_mpm DESTINATION ${CMAKE_INSTALL_PREFIX}/${USRP_MPM_PYTHON_DIR})
INSTALL(PROGRAMS
aurora_bist_test.py
+ usrp_update_fs
usrp_hwd.py
DESTINATION ${RUNTIME_DIR}
)