aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Hofrichter <joerg.hofrichter@ni.com>2020-01-22 18:14:18 +0100
committerMartin Braun <martin.braun@ettus.com>2020-01-22 12:54:54 -0800
commit84bb89878ce6fb08ed512532a0e934d89ca4b7d3 (patch)
tree69b1e9651fcf813e82d779813b9bef9787d24a03 /mpm/CMakeLists.txt
parent9450345649f5d502cca89658f674161a5f45a376 (diff)
downloaduhd-84bb89878ce6fb08ed512532a0e934d89ca4b7d3.tar.gz
uhd-84bb89878ce6fb08ed512532a0e934d89ca4b7d3.tar.bz2
uhd-84bb89878ce6fb08ed512532a0e934d89ca4b7d3.zip
mpm: cmake: adopt default enable values of modules
The cmake script (macro MPM_REGISTER_COMPONENT) has an issue that the default value is ignored which will be fixed in the following commit. As a result of this issue, the modules Mykonos, Magnesium, E320 and E300 never got enabled per default. It was always necessary to use an override like ENABLE_MYKONOS=ON. Therefore, change the default enable values so that a fix to MPM_REGISTER_COMPONENT does not change the current behavior.
Diffstat (limited to 'mpm/CMakeLists.txt')
-rw-r--r--mpm/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/mpm/CMakeLists.txt b/mpm/CMakeLists.txt
index 78759cc0b..ce40b7caa 100644
--- a/mpm/CMakeLists.txt
+++ b/mpm/CMakeLists.txt
@@ -144,10 +144,10 @@ elseif(MPM_DEVICE STREQUAL "e31x")
endif()
MPM_REGISTER_COMPONENT("LibMPM" ENABLE_LIBMPM ON "Boost_FOUND" OFF ON)
-MPM_REGISTER_COMPONENT("Mykonos" ENABLE_MYKONOS ON "ENABLE_LIBMPM" OFF OFF)
-MPM_REGISTER_COMPONENT("Magnesium" ENABLE_MAGNESIUM ON "ENABLE_MYKONOS" OFF OFF)
-MPM_REGISTER_COMPONENT("E320" ENABLE_E320 ON "ENABLE_LIBMPM" OFF OFF)
-MPM_REGISTER_COMPONENT("E300" ENABLE_E300 ON "ENABLE_LIBMPM" OFF OFF)
+MPM_REGISTER_COMPONENT("Mykonos" ENABLE_MYKONOS OFF "ENABLE_LIBMPM" OFF OFF)
+MPM_REGISTER_COMPONENT("Magnesium" ENABLE_MAGNESIUM OFF "ENABLE_MYKONOS" OFF OFF)
+MPM_REGISTER_COMPONENT("E320" ENABLE_E320 OFF "ENABLE_LIBMPM" OFF OFF)
+MPM_REGISTER_COMPONENT("E300" ENABLE_E300 OFF "ENABLE_LIBMPM" OFF OFF)
add_subdirectory(include)
include_directories(