aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Rode <andrej.rode@ettus.com>2017-03-21 19:42:44 -0700
committerMartin Braun <martin.braun@ettus.com>2017-12-22 15:03:44 -0800
commit1b4af85e10121ba6c89aa2d2ea064dd554076dba (patch)
tree3c1dc2b5b9e61dd249c3658dafc7732f558bb6e8 /mpm/CMakeLists.txt
parentd96ff2270cbaed482b4ef52230979d5de792783a (diff)
downloaduhd-1b4af85e10121ba6c89aa2d2ea064dd554076dba.tar.gz
uhd-1b4af85e10121ba6c89aa2d2ea064dd554076dba.tar.bz2
uhd-1b4af85e10121ba6c89aa2d2ea064dd554076dba.zip
mpm: cleanup CMakeLists, fixup minor bugs
Diffstat (limited to 'mpm/CMakeLists.txt')
-rw-r--r--mpm/CMakeLists.txt17
1 files changed, 6 insertions, 11 deletions
diff --git a/mpm/CMakeLists.txt b/mpm/CMakeLists.txt
index 0610a967d..73ec07657 100644
--- a/mpm/CMakeLists.txt
+++ b/mpm/CMakeLists.txt
@@ -30,15 +30,8 @@ ENDMACRO(USRP_PERIPHS_ADD_OBJECT)
MESSAGE(STATUS "")
MESSAGE(STATUS "Configuring Boost C++ Libraries...")
SET(BOOST_REQUIRED_COMPONENTS
- chrono
- date_time
- filesystem
- program_options
- python
- regex
- system
- unit_test_framework
- serialization
+ python
+ system
)
IF(MINGW)
LIST(APPEND BOOST_REQUIRED_COMPONENTS thread_win32)
@@ -77,8 +70,8 @@ MESSAGE(STATUS "Boost libraries: ${Boost_LIBRARIES}")
# Setup library configuration
########################################################################
SET(CMAKE_CXX_STANDARD 11)
-SET(MPM_DEVICE "tests" CACHE STRING "Choose a MPM device to build")
-SET_PROPERTY(CACHE MPM_DEVICE PROPERTY STRINGS tests n310)
+# SET(MPM_DEVICE "tests" CACHE STRING "Choose a MPM device to build")
+# SET_PROPERTY(CACHE MPM_DEVICE PROPERTY STRINGS tests)
SET(UHD_HOST_ROOT ${CMAKE_SOURCE_DIR}/../host)
@@ -89,6 +82,7 @@ INCLUDE_DIRECTORIES(
${UHD_HOST_ROOT}/include
)
+ADD_SUBDIRECTORY(dboards)
ADD_SUBDIRECTORY(lib)
IF(MPM_DEVICE STREQUAL tests)
ADD_SUBDIRECTORY(tests)
@@ -98,6 +92,7 @@ ENDIF(MPM_DEVICE STREQUAL tests)
MESSAGE("usrp_periphs objects: ${usrp_periphs_objects}")
ADD_LIBRARY(usrp-periphs SHARED ${usrp_periphs_objects})
+TARGET_LINK_LIBRARIES(usrp-periphs udev)
########################################################################
# Setup Python API
########################################################################