aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-02-28 15:44:24 -0800
committerMartin Braun <martin.braun@ettus.com>2018-03-05 15:56:41 -0800
commit94fcb32310eecad96f77394f9e66d69593e9d1f6 (patch)
treeb21264b938b0998f0f2210b912446bf18f245af1 /mpm/CMakeLists.txt
parent725debb96408f0e1134fe1f365c4afaf07f1a949 (diff)
downloaduhd-94fcb32310eecad96f77394f9e66d69593e9d1f6.tar.gz
uhd-94fcb32310eecad96f77394f9e66d69593e9d1f6.tar.bz2
uhd-94fcb32310eecad96f77394f9e66d69593e9d1f6.zip
mpm: cmake: Make default install path /usr
Diffstat (limited to 'mpm/CMakeLists.txt')
-rw-r--r--mpm/CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/mpm/CMakeLists.txt b/mpm/CMakeLists.txt
index 67130de4b..72d72bcfc 100644
--- a/mpm/CMakeLists.txt
+++ b/mpm/CMakeLists.txt
@@ -1,15 +1,24 @@
#
-# Copyright 2017 Ettus Research, National Instruments Company
+# Copyright 2017-2018 Ettus Research, a National Instruments Company
#
-# SPDX-License-Identifier: GPL-3.0
+# SPDX-License-Identifier: GPL-3.0-or-later
#
-cmake_minimum_required(VERSION 3.1)
+CMAKE_MINIMUM_REQUIRED(VERSION 3.1)
+PROJECT(MPM C CXX) # Also has Python, but CMake can take care of that later
+# Set the default value for CMAKE_INSTALL_PREFIX to /usr
+IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+ SET(CMAKE_INSTALL_PREFIX "/usr"
+ CACHE
+ PATH
+ "Default installation path for MPM"
+ FORCE
+ )
+ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
########################################################################
-# useful macros
+# useful macros
########################################################################
-
MACRO(USRP_PERIPHS_APPEND_SOURCES)
SET(usrp_periphs_sources ${usrp_periphs_sources} PARENT_SCOPE)
LIST(APPEND usrp_periphs_sources ${ARGV})