aboutsummaryrefslogtreecommitdiffstats
path: root/mpm/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Stapleton <brent.stapleton@ettus.com>2018-04-17 19:33:23 -0700
committerBrent Stapleton <bstapleton@g.hmc.edu>2018-07-18 15:37:27 -0700
commit300a5e3f6e5e845b4b8d093222e1c51ca4640f79 (patch)
tree62f8bb7bc7d847b8f32f1fe5b4c9c06ef608080e /mpm/CMakeLists.txt
parenta1d6530ce50ca9590739ffa40464747d3db968eb (diff)
downloaduhd-300a5e3f6e5e845b4b8d093222e1c51ca4640f79.tar.gz
uhd-300a5e3f6e5e845b4b8d093222e1c51ca4640f79.tar.bz2
uhd-300a5e3f6e5e845b4b8d093222e1c51ca4640f79.zip
mpm: initial commit of E320 code
Co-authored-by: Sugandha Gupta <sugandha.gupta@ettus.com>
Diffstat (limited to 'mpm/CMakeLists.txt')
-rw-r--r--mpm/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/mpm/CMakeLists.txt b/mpm/CMakeLists.txt
index 6ae8e5204..9fc24b98b 100644
--- a/mpm/CMakeLists.txt
+++ b/mpm/CMakeLists.txt
@@ -132,7 +132,7 @@ if(_has_no_psabi)
MESSAGE(STATUS "Disabling psABI warnings.")
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-psabi")
endif(_has_no_psabi)
-SET(MPM_ALL_DEVICES n3xx tests)
+SET(MPM_ALL_DEVICES n3xx e320 tests)
SET(MPM_DEVICE "n3xx" CACHE STRING "Choose an MPM device to build")
SET_PROPERTY(CACHE MPM_DEVICE PROPERTY STRINGS ${MPM_ALL_DEVICES})
# Validate MPM_DEVICE
@@ -146,11 +146,14 @@ endif()
IF(MPM_DEVICE STREQUAL "n3xx")
SET(ENABLE_MYKONOS ON)
SET(ENABLE_MAGNESIUM ON)
+ELSEIF(MPM_DEVICE STREQUAL "e320")
+ SET(ENABLE_E320 ON)
ENDIF()
MPM_REGISTER_COMPONENT("LibMPM" ENABLE_LIBMPM ON "Boost_FOUND" OFF ON)
MPM_REGISTER_COMPONENT("Mykonos" ENABLE_MYKONOS ON "ENABLE_LIBMPM" OFF OFF)
MPM_REGISTER_COMPONENT("Magnesium" ENABLE_MAGNESIUM ON "ENABLE_MYKONOS" OFF OFF)
+MPM_REGISTER_COMPONENT("E320" ENABLE_E320 ON "ENABLE_LIBMPM" OFF OFF)
ADD_SUBDIRECTORY(include)
INCLUDE_DIRECTORIES(