summaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-02-15 16:53:03 -0800
committerJosh Blum <josh@joshknows.com>2010-02-15 16:53:03 -0800
commitb2dc873c221fb48ee67dcfb3262fdf55a8725ed1 (patch)
tree5d9026f43520f2126656e4024a7f632e748b98ce /lib/CMakeLists.txt
parent8d76c9a40859182d601d6f58064ddb7181fb6ce6 (diff)
downloaduhd-b2dc873c221fb48ee67dcfb3262fdf55a8725ed1.tar.gz
uhd-b2dc873c221fb48ee67dcfb3262fdf55a8725ed1.tar.bz2
uhd-b2dc873c221fb48ee67dcfb3262fdf55a8725ed1.zip
Added CMakeLists.txt for the include dir.
Setting up the pkg config file through cmake. Added stuff to cmake to add optional flags.
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 46e487f7f..6150fd574 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -31,3 +31,5 @@ ADD_LIBRARY(uhd SHARED
TARGET_LINK_LIBRARIES(uhd uhd_usrp)
TARGET_LINK_LIBRARIES(uhd uhd_transport)
TARGET_LINK_LIBRARIES(uhd ${Boost_LIBRARIES})
+
+INSTALL(TARGETS uhd LIBRARY DESTINATION ${LIBRARY_DIR})