aboutsummaryrefslogtreecommitdiffstats
path: root/include/usrp_uhd/usrp/dboard/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-01-12 16:59:03 -0800
committerJosh Blum <josh@joshknows.com>2010-01-12 16:59:03 -0800
commit8fdffd2f77016fe95f4a78e16d2d728b650b4d05 (patch)
treed3cd9a5e2be1f77c034943f9711c7ca83f711083 /include/usrp_uhd/usrp/dboard/Makefile.am
parent087b97e0fc28793ea39d81e60b3fddae51c5929e (diff)
downloaduhd-8fdffd2f77016fe95f4a78e16d2d728b650b4d05.tar.gz
uhd-8fdffd2f77016fe95f4a78e16d2d728b650b4d05.tar.bz2
uhd-8fdffd2f77016fe95f4a78e16d2d728b650b4d05.zip
Added base classes for the usrp dboards to inherit.
Added a manager class for the subdevs that will create devices, and give out proxies to handle them.
Diffstat (limited to 'include/usrp_uhd/usrp/dboard/Makefile.am')
-rw-r--r--include/usrp_uhd/usrp/dboard/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/usrp_uhd/usrp/dboard/Makefile.am b/include/usrp_uhd/usrp/dboard/Makefile.am
index 19777b11a..d8c240351 100644
--- a/include/usrp_uhd/usrp/dboard/Makefile.am
+++ b/include/usrp_uhd/usrp/dboard/Makefile.am
@@ -8,4 +8,6 @@ SUBDIRS =
this_includedir = $(includedir)/usrp_uhd/usrp/dboard
this_include_HEADERS = \
- interface.hpp
+ base.hpp \
+ interface.hpp \
+ manager.hpp