summaryrefslogtreecommitdiffstats
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-02-15 16:53:03 -0800
committerJosh Blum <josh@joshknows.com>2010-02-15 16:53:03 -0800
commitb2dc873c221fb48ee67dcfb3262fdf55a8725ed1 (patch)
tree5d9026f43520f2126656e4024a7f632e748b98ce /include/CMakeLists.txt
parent8d76c9a40859182d601d6f58064ddb7181fb6ce6 (diff)
downloaduhd-b2dc873c221fb48ee67dcfb3262fdf55a8725ed1.tar.gz
uhd-b2dc873c221fb48ee67dcfb3262fdf55a8725ed1.tar.bz2
uhd-b2dc873c221fb48ee67dcfb3262fdf55a8725ed1.zip
Added CMakeLists.txt for the include dir.
Setting up the pkg config file through cmake. Added stuff to cmake to add optional flags.
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
new file mode 100644
index 000000000..34b705cab
--- /dev/null
+++ b/include/CMakeLists.txt
@@ -0,0 +1,24 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+
+ADD_SUBDIRECTORY(uhd)
+
+INSTALL(FILES
+ uhd.hpp
+ DESTINATION ${HEADER_DIR}
+)