aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-05-12 18:59:15 -0700
committerJosh Blum <josh@joshknows.com>2010-05-12 18:59:15 -0700
commit9fd30e928e3599b43b3d9bbd7be82793a62d7944 (patch)
tree2840db36c2d4f8e8f2ac22cf4cdc2679777a46bd /host/utils/CMakeLists.txt
parent81f211c94f761c92baaf1a2997a7f9b9b7718182 (diff)
downloaduhd-9fd30e928e3599b43b3d9bbd7be82793a62d7944.tar.gz
uhd-9fd30e928e3599b43b3d9bbd7be82793a62d7944.tar.bz2
uhd-9fd30e928e3599b43b3d9bbd7be82793a62d7944.zip
Added card burner python app with gui and windows support.
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 3c2236379..d28576e8c 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -19,12 +19,16 @@ ADD_EXECUTABLE(uhd_find_devices uhd_find_devices.cpp)
TARGET_LINK_LIBRARIES(uhd_find_devices uhd)
INSTALL(TARGETS uhd_find_devices RUNTIME DESTINATION ${RUNTIME_DIR})
-ADD_EXECUTABLE(usrp2_burner usrp2_burner.cpp)
-TARGET_LINK_LIBRARIES(usrp2_burner uhd)
-INSTALL(TARGETS usrp2_burner RUNTIME DESTINATION ${PKG_DATA_DIR}/utils)
+ADD_EXECUTABLE(usrp2_addr_burner usrp2_addr_burner.cpp)
+TARGET_LINK_LIBRARIES(usrp2_addr_burner uhd)
+INSTALL(TARGETS usrp2_addr_burner RUNTIME DESTINATION ${PKG_DATA_DIR}/utils)
ADD_EXECUTABLE(uhd_burn_db_eeprom uhd_burn_db_eeprom.cpp)
TARGET_LINK_LIBRARIES(uhd_burn_db_eeprom uhd)
INSTALL(TARGETS uhd_burn_db_eeprom RUNTIME DESTINATION ${PKG_DATA_DIR}/utils)
-INSTALL(PROGRAMS usrp2_recovery.py DESTINATION ${PKG_DATA_DIR}/utils)
+INSTALL(PROGRAMS
+ usrp2_recovery.py
+ usrp2_card_burner.py
+ DESTINATION ${PKG_DATA_DIR}/utils
+)