aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-02-22 15:27:51 -0800
committerMartin Braun <martin.braun@ettus.com>2018-03-05 13:53:17 -0800
commit988b6ecab417dc8e5ac225e112b33c2b2f6193ad (patch)
tree82c895bec7bdb5039c108f70c36ce81f3264ab2b /host/utils/CMakeLists.txt
parentb553be8e07b99fca73d32546ea13f92d84cc47e3 (diff)
downloaduhd-988b6ecab417dc8e5ac225e112b33c2b2f6193ad.tar.gz
uhd-988b6ecab417dc8e5ac225e112b33c2b2f6193ad.tar.bz2
uhd-988b6ecab417dc8e5ac225e112b33c2b2f6193ad.zip
utils: Removed deprecated utilities
This removes all the tools that have been declared deprecated for a while. No functionality is removed, all utilities have a separate equivalent, e.g., with uhd_image_loader.
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt33
1 files changed, 1 insertions, 32 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 5f8309587..769314f33 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -2,7 +2,7 @@
# Copyright 2010-2015 Ettus Research LLC
# Copyright 2018 Ettus Research, a National Instruments Company
#
-# SPDX-License-Identifier: GPL-3.0
+# SPDX-License-Identifier: GPL-3.0-or-later
#
########################################################################
@@ -16,12 +16,6 @@ SET(util_runtime_sources
uhd_cal_rx_iq_balance.cpp
uhd_cal_tx_dc_offset.cpp
uhd_cal_tx_iq_balance.cpp
- usrp_n2xx_simple_net_burner.cpp
-)
-
-SET(x3xx_burner_sources
- usrp_x3xx_fpga_burner.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/../lib/usrp/x300/cdecode.c
)
find_package(UDev)
@@ -39,13 +33,6 @@ FOREACH(util_source ${util_runtime_sources})
UHD_INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${RUNTIME_DIR} COMPONENT utilities)
ENDFOREACH(util_source)
-IF(ENABLE_X300)
- INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/lib/usrp/x300)
- ADD_EXECUTABLE(usrp_x3xx_fpga_burner ${x3xx_burner_sources})
- TARGET_LINK_LIBRARIES(usrp_x3xx_fpga_burner uhd ${Boost_LIBRARIES})
- UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${RUNTIME_DIR} COMPONENT utilities)
-ENDIF(ENABLE_X300)
-
########################################################################
# Utilities that get installed into the share path
########################################################################
@@ -79,16 +66,6 @@ IF(ENABLE_OCTOCLOCK)
LIST(APPEND util_share_sources
octoclock_burn_eeprom.cpp
)
-
- SET(octoclock_burner_sources
- octoclock_firmware_burner.cpp
- ${CMAKE_SOURCE_DIR}/lib/utils/ihex.cpp
- )
-
- INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/lib/usrp_clock/octoclock)
- ADD_EXECUTABLE(octoclock_firmware_burner ${octoclock_burner_sources})
- TARGET_LINK_LIBRARIES(octoclock_firmware_burner uhd ${Boost_LIBRARIES})
- UHD_INSTALL(TARGETS octoclock_firmware_burner RUNTIME DESTINATION ${RUNTIME_DIR} COMPONENT utilities)
ENDIF(ENABLE_OCTOCLOCK)
IF(LINUX AND ENABLE_USB)
@@ -114,13 +91,6 @@ FOREACH(util_source ${util_share_sources_py})
)
ENDFOREACH(util_source)
-IF(ENABLE_USRP2)
- UHD_INSTALL(TARGETS usrp_n2xx_simple_net_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
-ENDIF(ENABLE_USRP2)
-IF(ENABLE_X300)
- UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
-ENDIF(ENABLE_X300)
-
#UHD images downloader configuration
FILE(READ ${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt CMAKE_MANIFEST_CONTENTS)
CONFIGURE_FILE(
@@ -155,7 +125,6 @@ ENDIF(NOT HAVE_PYTHON_MODULE_REQUESTS)
IF(ENABLE_USRP2)
SET(burners
usrp2_card_burner.py
- usrp_n2xx_net_burner.py
)
IF(WIN32 AND UHD_RELEASE_MODE) #include dd.exe