aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2015-10-23 14:05:36 -0700
committerMartin Braun <martin.braun@ettus.com>2015-10-26 16:56:04 -0700
commit4dd7cea6e0b9004b1c344321e8903cbd528fcaff (patch)
tree1a1e8a07e9b9623e59110272f14b0281c2fbb09f /host/utils/CMakeLists.txt
parent777352e7a4f24f21c1c0ea1db62a4d17726a1093 (diff)
downloaduhd-4dd7cea6e0b9004b1c344321e8903cbd528fcaff.tar.gz
uhd-4dd7cea6e0b9004b1c344321e8903cbd528fcaff.tar.bz2
uhd-4dd7cea6e0b9004b1c344321e8903cbd528fcaff.zip
cmake: Proper selection of files for ENABLE_X300
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 1ef7766f9..7e23b18c3 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -48,9 +48,11 @@ FOREACH(util_source ${util_runtime_sources})
UHD_INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${RUNTIME_DIR} COMPONENT utilities)
ENDFOREACH(util_source)
-ADD_EXECUTABLE(usrp_x3xx_fpga_burner ${x3xx_burner_sources})
-TARGET_LINK_LIBRARIES(usrp_x3xx_fpga_burner uhd ${Boost_LIBRARIES})
-UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${RUNTIME_DIR} COMPONENT utilities)
+IF(ENABLE_X300)
+ ADD_EXECUTABLE(usrp_x3xx_fpga_burner ${x3xx_burner_sources})
+ TARGET_LINK_LIBRARIES(usrp_x3xx_fpga_burner uhd ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${RUNTIME_DIR} COMPONENT utilities)
+ENDIF(ENABLE_X300)
########################################################################
# Utilities that get installed into the share path
@@ -121,8 +123,12 @@ FOREACH(util_source ${util_share_sources_py})
)
ENDFOREACH(util_source)
-UHD_INSTALL(TARGETS usrp_n2xx_simple_net_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
-UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
+IF(ENABLE_USRP2)
+ UHD_INSTALL(TARGETS usrp_n2xx_simple_net_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
+ENDIF(ENABLE_USRP2)
+IF(ENABLE_X300)
+ UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
+ENDIF(ENABLE_X300)
#UHD images downloader configuration
CONFIGURE_FILE(