aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2013-05-03 10:42:24 -0700
committerNicholas Corgan <nick.corgan@ettus.com>2013-05-03 10:50:14 -0700
commit3cccb57414c87d3af97974870d877393ab5a51ff (patch)
treea1f8a56534fc9dcd958d22401d1f7e8fd2e28f4d /host/utils/CMakeLists.txt
parentb8bdbc51312b1a1cf80dbc251a8ebb537ac9d5a9 (diff)
downloaduhd-3cccb57414c87d3af97974870d877393ab5a51ff.tar.gz
uhd-3cccb57414c87d3af97974870d877393ab5a51ff.tar.bz2
uhd-3cccb57414c87d3af97974870d877393ab5a51ff.zip
Made uhd_images_downloader more robust to match Debian's uhd_firmware_installer
* Uses custom User Agent * Compares md5sum of downloaded zip file to stored value
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 9e997071e..6fc11d747 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -76,6 +76,14 @@ INSTALL(PROGRAMS
DESTINATION ${PKG_LIB_DIR}/utils
COMPONENT utilities
)
+IF(LINUX)
+ INSTALL(PROGRAMS
+ ${CMAKE_CURRENT_BINARY_DIR}/uhd_images_downloader.py
+ RENAME uhd_images_downloader
+ DESTINATION ${RUNTIME_DIR}
+ COMPONENT utilities
+ )
+ENDIF(LINUX)
IF(ENABLE_USRP2)
IF(WIN32 AND UHD_RELEASE_MODE) #include dd.exe