aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorPhilip Balister <philip@opensdr.com>2010-08-28 15:30:38 -0400
committerPhilip Balister <philip@opensdr.com>2010-08-28 15:30:38 -0400
commita79d320d7691fea82c9194d59a5d4dc7bbb40317 (patch)
treef98026f11ea12201214522ba4ec5f717448b55cc /host/utils/CMakeLists.txt
parent63a07eb9c8ba49657a815e62e8937c65e2a8362a (diff)
downloaduhd-a79d320d7691fea82c9194d59a5d4dc7bbb40317.tar.gz
uhd-a79d320d7691fea82c9194d59a5d4dc7bbb40317.tar.bz2
uhd-a79d320d7691fea82c9194d59a5d4dc7bbb40317.zip
Move fpga-downloader and usrp-e-loopback into utils so they get packaged
for installation on the USRP Embedded.
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index c349a9018..0e3f81d0a 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -24,9 +24,17 @@ TARGET_LINK_LIBRARIES(uhd_find_devices uhd)
ADD_EXECUTABLE(uhd_usrp_probe uhd_usrp_probe.cpp)
TARGET_LINK_LIBRARIES(uhd_usrp_probe uhd)
+ADD_EXECUTABLE(fpga-downloader fpga-downloader.cpp)
+TARGET_LINK_LIBRARIES(fpga-downloader)
+
+ADD_EXECUTABLE(usrp-e-loopback usrp-e-loopback.c)
+TARGET_LINK_LIBRARIES(usrp-e-loopback pthread)
+
INSTALL(TARGETS
uhd_find_devices
uhd_usrp_probe
+ fpga-downloader
+ usrp-e-loopback
RUNTIME DESTINATION ${RUNTIME_DIR}
)