aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-11-13 21:53:22 -0800
committerBrent Stapleton <bstapleton@g.hmc.edu>2018-11-14 14:10:09 -0800
commita69ab0c23a0c38e3fed3e412df36538d8959d23c (patch)
treee6669a138dad84f79c46588f43a38c69dda90246 /host/utils/CMakeLists.txt
parent4247f025020d7dd1f696dfbd3cce248957d6ace7 (diff)
downloaduhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.tar.gz
uhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.tar.bz2
uhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.zip
cmake: Update coding style to use lowercase commands
Also updates our coding style file. Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code (with GNU compliant sed): cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done > convert.sed \ && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' \ '*CMakeLists.txt' | xargs -0 gsed -i -f convert.sed && rm convert.sed (Make sure the backslashes don't get mangled!)
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt112
1 files changed, 56 insertions, 56 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index b8dd70a54..4e8d8e5f0 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -8,7 +8,7 @@
########################################################################
# Utilities that get installed into the runtime path
########################################################################
-SET(util_runtime_sources
+set(util_runtime_sources
uhd_config_info.cpp
uhd_find_devices.cpp
uhd_usrp_probe.cpp
@@ -19,89 +19,89 @@ SET(util_runtime_sources
)
find_package(UDev)
-IF(ENABLE_E300 AND NOT E300_FORCE_NETWORK)
- IF(UDEV_FOUND)
- LIST(APPEND util_runtime_sources usrp_e3x0_network_mode.cpp)
- ENDIF(UDEV_FOUND)
-ENDIF(ENABLE_E300 AND NOT E300_FORCE_NETWORK)
+if(ENABLE_E300 AND NOT E300_FORCE_NETWORK)
+ if(UDEV_FOUND)
+ list(APPEND util_runtime_sources usrp_e3x0_network_mode.cpp)
+ endif(UDEV_FOUND)
+endif(ENABLE_E300 AND NOT E300_FORCE_NETWORK)
#for each source: build an executable and install
-FOREACH(util_source ${util_runtime_sources})
- GET_FILENAME_COMPONENT(util_name ${util_source} NAME_WE)
- ADD_EXECUTABLE(${util_name} ${util_source})
- TARGET_LINK_LIBRARIES(${util_name} uhd ${Boost_LIBRARIES})
+foreach(util_source ${util_runtime_sources})
+ get_filename_component(util_name ${util_source} NAME_WE)
+ add_executable(${util_name} ${util_source})
+ target_link_libraries(${util_name} uhd ${Boost_LIBRARIES})
UHD_INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${RUNTIME_DIR} COMPONENT utilities)
-ENDFOREACH(util_source)
+endforeach(util_source)
########################################################################
# Utilities that get installed into the share path
########################################################################
-SET(util_share_sources
+set(util_share_sources
converter_benchmark.cpp
query_gpsdo_sensors.cpp
usrp_burn_db_eeprom.cpp
usrp_burn_mb_eeprom.cpp
)
-SET(util_share_sources_py
+set(util_share_sources_py
converter_benchmark.py
)
-IF(ENABLE_USB)
- LIST(APPEND util_share_sources
+if(ENABLE_USB)
+ list(APPEND util_share_sources
fx2_init_eeprom.cpp
)
- INCLUDE_DIRECTORIES(${LIBUSB_INCLUDE_DIRS})
- IF(ENABLE_B200)
- LIST(APPEND util_share_sources
+ include_directories(${LIBUSB_INCLUDE_DIRS})
+ if(ENABLE_B200)
+ list(APPEND util_share_sources
b2xx_fx3_utils.cpp
)
# Additional include directories for b2xx_fx3_utils
- INCLUDE_DIRECTORIES(
+ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}/../lib/include
${CMAKE_CURRENT_SOURCE_DIR}/../lib/usrp/b200
${CMAKE_CURRENT_SOURCE_DIR}/../lib/usrp/common
${CMAKE_CURRENT_SOURCE_DIR}/../lib/usrp/common/ad9361_driver
)
- ENDIF(ENABLE_B200)
-ENDIF(ENABLE_USB)
-IF(ENABLE_OCTOCLOCK)
- LIST(APPEND util_share_sources
+ endif(ENABLE_B200)
+endif(ENABLE_USB)
+if(ENABLE_OCTOCLOCK)
+ list(APPEND util_share_sources
octoclock_burn_eeprom.cpp
)
-ENDIF(ENABLE_OCTOCLOCK)
+endif(ENABLE_OCTOCLOCK)
-IF(LINUX AND ENABLE_USB)
+if(LINUX AND ENABLE_USB)
UHD_INSTALL(FILES
uhd-usrp.rules
DESTINATION ${PKG_LIB_DIR}/utils
COMPONENT utilities
)
-ENDIF(LINUX AND ENABLE_USB)
+endif(LINUX AND ENABLE_USB)
#for each source: build an executable and install
-FOREACH(util_source ${util_share_sources})
- GET_FILENAME_COMPONENT(util_name ${util_source} NAME_WE)
- ADD_EXECUTABLE(${util_name} ${util_source})
- TARGET_LINK_LIBRARIES(${util_name} uhd ${Boost_LIBRARIES})
+foreach(util_source ${util_share_sources})
+ get_filename_component(util_name ${util_source} NAME_WE)
+ add_executable(${util_name} ${util_source})
+ target_link_libraries(${util_name} uhd ${Boost_LIBRARIES})
UHD_INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
-ENDFOREACH(util_source)
-FOREACH(util_source ${util_share_sources_py})
+endforeach(util_source)
+foreach(util_source ${util_share_sources_py})
UHD_INSTALL(PROGRAMS
${CMAKE_CURRENT_SOURCE_DIR}/${util_source}
DESTINATION ${PKG_LIB_DIR}/utils
COMPONENT utilities
)
-ENDFOREACH(util_source)
+endforeach(util_source)
#UHD images downloader configuration
-FILE(READ ${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt CMAKE_MANIFEST_CONTENTS)
-CONFIGURE_FILE(
+file(READ ${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt CMAKE_MANIFEST_CONTENTS)
+configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/uhd_images_downloader.py.in
${CMAKE_CURRENT_BINARY_DIR}/uhd_images_downloader.py
@ONLY)
# TODO: FIXME when know how.
# This is a hack to force cmake regenerate uhd_images_downloader.py
# whenever manifest.txt file changed.
-CONFIGURE_FILE(
+configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt
${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt
COPYONLY)
@@ -111,26 +111,26 @@ UHD_INSTALL(PROGRAMS
DESTINATION ${PKG_LIB_DIR}/utils
COMPONENT utilities
)
-IF(LINUX)
+if(LINUX)
UHD_INSTALL(PROGRAMS
${CMAKE_CURRENT_BINARY_DIR}/uhd_images_downloader.py
RENAME uhd_images_downloader
DESTINATION ${RUNTIME_DIR}
COMPONENT utilities
)
-ENDIF(LINUX)
-IF(NOT HAVE_PYTHON_MODULE_REQUESTS)
- MESSAGE(WARNING "Python module `requests' not found -- uhd_images_downloader.py will not work without it.")
- MESSAGE(WARNING "You may be able to install this by running 'pip install requests'")
-ENDIF(NOT HAVE_PYTHON_MODULE_REQUESTS)
+endif(LINUX)
+if(NOT HAVE_PYTHON_MODULE_REQUESTS)
+ message(WARNING "Python module `requests' not found -- uhd_images_downloader.py will not work without it.")
+ message(WARNING "You may be able to install this by running 'pip install requests'")
+endif(NOT HAVE_PYTHON_MODULE_REQUESTS)
-IF(ENABLE_USRP2)
- SET(burners
+if(ENABLE_USRP2)
+ set(burners
usrp2_card_burner.py
)
- IF(WIN32 AND UHD_RELEASE_MODE) #include dd.exe
- FILE(DOWNLOAD
+ if(WIN32 AND UHD_RELEASE_MODE) #include dd.exe
+ file(DOWNLOAD
"http://files.ettus.com/dd.exe"
${CMAKE_CURRENT_BINARY_DIR}/dd.exe
)
@@ -139,8 +139,8 @@ IF(ENABLE_USRP2)
DESTINATION ${PKG_LIB_DIR}/utils
COMPONENT utilities
)
- ENDIF(WIN32 AND UHD_RELEASE_MODE)
- IF(LINUX)
+ endif(WIN32 AND UHD_RELEASE_MODE)
+ if(LINUX)
UHD_INSTALL(PROGRAMS
usrp2_recovery.py
DESTINATION ${PKG_LIB_DIR}/utils
@@ -152,22 +152,22 @@ IF(ENABLE_USRP2)
DESTINATION ${RUNTIME_DIR}
COMPONENT utilities
)
- ENDIF(LINUX)
- FOREACH(burner ${burners})
+ endif(LINUX)
+ foreach(burner ${burners})
UHD_INSTALL(PROGRAMS
${burner}
DESTINATION ${PKG_LIB_DIR}/utils
COMPONENT utilities
)
- ENDFOREACH(burner ${burners})
+ endforeach(burner ${burners})
-ENDIF(ENABLE_USRP2)
+endif(ENABLE_USRP2)
########################################################################
# Other files that are not utilities or executables
########################################################################
-IF(WIN32)
- SET(windows_extra_files
+if(WIN32)
+ set(windows_extra_files
FastSendDatagramThreshold.reg
)
UHD_INSTALL(
@@ -175,6 +175,6 @@ IF(WIN32)
DESTINATION ${PKG_DATA_DIR}
COMPONENT utilities
)
-ENDIF(WIN32)
+endif(WIN32)
-ADD_SUBDIRECTORY(latency)
+add_subdirectory(latency)