aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Stapleton <brent.stapleton@ettus.com>2017-12-20 14:27:05 -0800
committerMartin Braun <martin.braun@ettus.com>2018-01-23 15:03:48 -0800
commit28405e54056b52fcd04fc71c6c2d72f3dc8c31cf (patch)
tree196bfb5bdf051bc640f1ca858d3bbe980ec626e5 /host/utils/CMakeLists.txt
parent37d4eabf279cb6869b244d4320db991c9aca7a97 (diff)
downloaduhd-28405e54056b52fcd04fc71c6c2d72f3dc8c31cf.tar.gz
uhd-28405e54056b52fcd04fc71c6c2d72f3dc8c31cf.tar.bz2
uhd-28405e54056b52fcd04fc71c6c2d72f3dc8c31cf.zip
utils: refactor uhd_images_downloader
Changing structure of the files.ettus.com images directory, and updating uhd_images_downloader correspondingly. The images downloader now downloads a number of smaller archives of images, instead of one large archive containing all of our images. Furthermore, the images downloader maintains an inventory of currently installed images, so that images are not redownloaded unnecessarily. When called with no arguments, behavior should not change. CMake variables are used to populate a number of fields in the images downloader, including the contents of the manifest file. Reviewed-by: Martin Braun <martin.braun@ettus.com> Reviewed-by: Ashish Chaudhari <ashish.chaudhari@ettus.com>
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 78870f7bc..6ecfb4ba3 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -121,6 +121,7 @@ IF(ENABLE_X300)
ENDIF(ENABLE_X300)
#UHD images downloader configuration
+FILE(READ ${CMAKE_CURRENT_SOURCE_DIR}/../../images/manifest.txt CMAKE_MANIFEST_CONTENTS)
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/uhd_images_downloader.py.in
${CMAKE_CURRENT_BINARY_DIR}/uhd_images_downloader.py