aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-07-07 02:23:38 +0000
committerJosh Blum <josh@joshknows.com>2010-07-07 02:23:38 +0000
commitf2e9d3ed0941dc5738149dd82d1eac158bdf0a0f (patch)
tree82a350987e32cd329ab5fe56b6dd9fbfef08230f /host/utils/CMakeLists.txt
parent998fee6ef064f1d53a61dd0eec79276d1e85291e (diff)
parent5c2cccfe8c4a9c6c912a4d18dc1e7a6f84c79609 (diff)
downloaduhd-f2e9d3ed0941dc5738149dd82d1eac158bdf0a0f.tar.gz
uhd-f2e9d3ed0941dc5738149dd82d1eac158bdf0a0f.tar.bz2
uhd-f2e9d3ed0941dc5738149dd82d1eac158bdf0a0f.zip
Merge branch 'master' of ettus.sourcerepo.com:ettus/uhdpriv into usrp_e
Conflicts: host/examples/rx_timed_samples.cpp
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt26
1 files changed, 20 insertions, 6 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 8d260c06c..c349a9018 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -15,21 +15,35 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
+########################################################################
+# Utilities that get installed into the runtime path
+########################################################################
ADD_EXECUTABLE(uhd_find_devices uhd_find_devices.cpp)
TARGET_LINK_LIBRARIES(uhd_find_devices uhd)
-INSTALL(TARGETS uhd_find_devices RUNTIME DESTINATION ${RUNTIME_DIR})
ADD_EXECUTABLE(uhd_usrp_probe uhd_usrp_probe.cpp)
TARGET_LINK_LIBRARIES(uhd_usrp_probe uhd)
-INSTALL(TARGETS uhd_usrp_probe RUNTIME DESTINATION ${RUNTIME_DIR})
+INSTALL(TARGETS
+ uhd_find_devices
+ uhd_usrp_probe
+ RUNTIME DESTINATION ${RUNTIME_DIR}
+)
+
+########################################################################
+# Utilities that get installed into the share path
+########################################################################
ADD_EXECUTABLE(usrp2_addr_burner usrp2_addr_burner.cpp)
TARGET_LINK_LIBRARIES(usrp2_addr_burner uhd)
-INSTALL(TARGETS usrp2_addr_burner RUNTIME DESTINATION ${PKG_DATA_DIR}/utils)
-ADD_EXECUTABLE(uhd_burn_db_eeprom uhd_burn_db_eeprom.cpp)
-TARGET_LINK_LIBRARIES(uhd_burn_db_eeprom uhd)
-INSTALL(TARGETS uhd_burn_db_eeprom RUNTIME DESTINATION ${PKG_DATA_DIR}/utils)
+ADD_EXECUTABLE(usrp_burn_db_eeprom usrp_burn_db_eeprom.cpp)
+TARGET_LINK_LIBRARIES(usrp_burn_db_eeprom uhd)
+
+INSTALL(TARGETS
+ usrp2_addr_burner
+ usrp_burn_db_eeprom
+ RUNTIME DESTINATION ${PKG_DATA_DIR}/utils
+)
INSTALL(PROGRAMS
usrp2_recovery.py