aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-06-01 12:31:17 -0700
committerMartin Braun <martin.braun@ettus.com>2019-11-26 11:49:12 -0800
commitf7cb6ee0d67afaed499cec9e8e8d0d481a65dd29 (patch)
tree20d7381f78b4f463330cb7042b36faddb95aaa60 /host/tests/CMakeLists.txt
parent4bbbedbb7ea3fd8179e7f021fd9471eddd394f35 (diff)
downloaduhd-f7cb6ee0d67afaed499cec9e8e8d0d481a65dd29.tar.gz
uhd-f7cb6ee0d67afaed499cec9e8e8d0d481a65dd29.tar.bz2
uhd-f7cb6ee0d67afaed499cec9e8e8d0d481a65dd29.zip
lib: Simplify implementation of uhd::get_system_time() to use <chrono>
uhd::get_system_time() is currently only used in USRP1 code, and it turns out that our "optimized", platform-dependent implementation still is a little slower than straight-up chrono. We therefore remove all the special cases, and replace them with a single, standard solution.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 769c09796..e476eb61b 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -157,6 +157,12 @@ UHD_ADD_NONAPI_TEST(
)
UHD_ADD_NONAPI_TEST(
+ TARGET "system_time_test.cpp"
+ EXTRA_SOURCES
+ "${CMAKE_SOURCE_DIR}/lib/utils/system_time.cpp"
+)
+
+UHD_ADD_NONAPI_TEST(
TARGET "nocscript_ftable_test.cpp"
EXTRA_SOURCES
${CMAKE_SOURCE_DIR}/lib/rfnoc/nocscript/function_table.cpp