aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-03-24 16:54:11 -0700
committerMartin Braun <martin.braun@ettus.com>2019-11-26 11:49:13 -0800
commitefb1d5a4729ea892ea03b8d0265aae9e8fadfff1 (patch)
tree23cd4dbf85c635d381aaf7b0f6e9bd15eeca08fc /host/tests/CMakeLists.txt
parent44f9bca2c5b561fa3f5f08d0d616c91d2142cbf9 (diff)
downloaduhd-efb1d5a4729ea892ea03b8d0265aae9e8fadfff1.tar.gz
uhd-efb1d5a4729ea892ea03b8d0265aae9e8fadfff1.tar.bz2
uhd-efb1d5a4729ea892ea03b8d0265aae9e8fadfff1.zip
rfnoc: Add properties, nodes, and accessors
Adds the following classes: - uhd::rfnoc::node_t, the base class for RFNoC nodes - uhd::rfnoc::node_accessor_t, a class to access private properties - uhd::rfnoc::res_source_info, a struct that identifies where properties come from - uhd::rfnoc::property_t, and property_base_t (its parent) - uhd::rfnoc::prop_accessor_t, a class to access properties Add always dirty property (dirtifier). Also adds unit tests for properties.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index e4255196b..eab27833b 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -53,6 +53,7 @@ set(test_sources
expert_test.cpp
fe_conn_test.cpp
rfnoc_chdr_test.cpp
+ rfnoc_node_test.cpp
)
set(benchmark_sources
@@ -72,6 +73,7 @@ if(ENABLE_RFNOC)
rate_node_test.cpp
stream_sig_test.cpp
tick_node_test.cpp
+ rfnoc_property_test.cpp
)
endif(ENABLE_RFNOC)