aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLane Kolbly <lane.kolbly@ni.com>2020-06-22 17:22:56 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-06-25 13:36:08 -0500
commite9ae5fb949903cce1720b75b894401930cce1ebe (patch)
tree218233fd572d6318fcdfb6e661eae74fe88e485a /host/tests/CMakeLists.txt
parente08830cbe5609645462190aa0c1a9e234353f38a (diff)
downloaduhd-e9ae5fb949903cce1720b75b894401930cce1ebe.tar.gz
uhd-e9ae5fb949903cce1720b75b894401930cce1ebe.tar.bz2
uhd-e9ae5fb949903cce1720b75b894401930cce1ebe.zip
uhd: Add discoverable_features API
The "discoverable features" API handles how clients access the myriad features we offer, without simply adding a million has_FOO and do_FOO methods to radio_control and multi_usrp. discoverable_features allows clients to query the existance of, enumerate, and ultimately they get (by enum or by type) an object which implements their wanted feature.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 8c8a1cbc3..47ca5b79f 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -32,6 +32,7 @@ set(test_sources
constrained_device_args_test.cpp
convert_test.cpp
dict_test.cpp
+ discoverable_feature_test.cpp
eeprom_utils_test.cpp
error_test.cpp
fp_compare_delta_test.cpp