aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-01-17 16:02:55 -0800
committerMartin Braun <martin.braun@ettus.com>2018-01-18 11:26:21 -0800
commite504e6d9943186ba4d963ed977cbdb461bead755 (patch)
treecab19d65a9ff452c23f51d9c03001c6d16902376 /host/tests/CMakeLists.txt
parentb18b304f03d6a371b9eb9b30fdf1ec09b504b2c5 (diff)
downloaduhd-e504e6d9943186ba4d963ed977cbdb461bead755.tar.gz
uhd-e504e6d9943186ba4d963ed977cbdb461bead755.tar.bz2
uhd-e504e6d9943186ba4d963ed977cbdb461bead755.zip
uhdlib: Update constrained_device_args_t
- Allow enums to be non-consecutive - Move to uhdlib/ - Add unit tests - Updated N230 use of constrained_device_args_t
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 6f78f8d3e..0741191f2 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -19,6 +19,7 @@ SET(test_sources
cast_test.cpp
cal_container_test.cpp
chdr_test.cpp
+ constrained_device_args_test.cpp
convert_test.cpp
dict_test.cpp
error_test.cpp
@@ -69,6 +70,8 @@ IF(ENABLE_C_API)
)
ENDIF(ENABLE_C_API)
+INCLUDE_DIRECTORIES("${CMAKE_SOURCE_DIR}/lib/include")
+
#for each source: build an executable, register it as a test
FOREACH(test_source ${test_sources})
GET_FILENAME_COMPONENT(test_name ${test_source} NAME_WE)