aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLane Kolbly <lane.kolbly@ni.com>2020-06-22 18:06:38 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-06-25 13:36:08 -0500
commitd6cb55ef08f51c9ebef57e5bbcb95b03a65972a9 (patch)
tree8b8f1350d9d45d513f00e2b8e836a52600d27e66 /host/tests/CMakeLists.txt
parente9ae5fb949903cce1720b75b894401930cce1ebe (diff)
downloaduhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.tar.gz
uhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.tar.bz2
uhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.zip
uhd: Create discoverable feature registry implementation
Classes which want to implement discoverable_feature can simply inherit from this registry and get access to an ergonomic map-backed registry of features.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 47ca5b79f..6626b9c3a 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -32,7 +32,6 @@ set(test_sources
constrained_device_args_test.cpp
convert_test.cpp
dict_test.cpp
- discoverable_feature_test.cpp
eeprom_utils_test.cpp
error_test.cpp
fp_compare_delta_test.cpp
@@ -339,6 +338,12 @@ UHD_ADD_NONAPI_TEST(
${CMAKE_SOURCE_DIR}/lib/usrp/common/pwr_cal_mgr.cpp
)
+UHD_ADD_NONAPI_TEST(
+ TARGET "discoverable_feature_test.cpp"
+ EXTRA_SOURCES
+ ${CMAKE_SOURCE_DIR}/lib/features/discoverable_feature_registry.cpp
+)
+
########################################################################
# demo of a loadable module
########################################################################