aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Williams <alex.williams@ni.com>2019-12-11 13:44:17 -0800
committerBrent Stapleton <brent.stapleton@ettus.com>2019-12-20 16:32:22 -0800
commitcb400696bf2fbe82eea0f38d04a1771ccf6fd868 (patch)
treee28ef6a8f166b68cc49f4a7394f122069e661be1 /host/tests/CMakeLists.txt
parent6d6d0f22eb6a86be65b107c0d3387f9680d78ff6 (diff)
downloaduhd-cb400696bf2fbe82eea0f38d04a1771ccf6fd868.tar.gz
uhd-cb400696bf2fbe82eea0f38d04a1771ccf6fd868.tar.bz2
uhd-cb400696bf2fbe82eea0f38d04a1771ccf6fd868.zip
tests: Port polling-mode dpdk_test to new DPDK framework
The mock_send_transport and mock_recv_transport are used, which ends up with two layers of flow control. More work may be needed here for comparisons with the old data.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 2c53e4905..d25c88400 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -118,6 +118,22 @@ endmacro(UHD_ADD_NONAPI_TEST)
if(ENABLE_DPDK)
find_package(DPDK)
UHD_ADD_NONAPI_TEST(
+ TARGET "dpdk_test.cpp"
+ EXTRA_SOURCES
+ ${CMAKE_SOURCE_DIR}/lib/utils/config_parser.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/paths.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/pathslib.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/prefs.cpp
+ ${CMAKE_SOURCE_DIR}/lib/transport/adapter.cpp
+ ${CMAKE_SOURCE_DIR}/lib/transport/uhd-dpdk/dpdk_common.cpp
+ ${CMAKE_SOURCE_DIR}/lib/transport/uhd-dpdk/dpdk_io_service.cpp
+ ${CMAKE_SOURCE_DIR}/lib/transport/udp_dpdk_link.cpp
+ INCLUDE_DIRS
+ ${DPDK_INCLUDE_DIR}
+ EXTRA_LIBS ${DPDK_LIBRARIES}
+ NOAUTORUN # Don't register for auto-run, it requires special config
+ )
+ UHD_ADD_NONAPI_TEST(
TARGET "dpdk_port_test.cpp"
EXTRA_SOURCES
${CMAKE_SOURCE_DIR}/lib/utils/config_parser.cpp