aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-03-27 17:32:09 -0700
committerMartin Braun <martin.braun@ettus.com>2019-04-01 23:39:35 -0500
commitbeb1f3c207bcf1ebc6ca1e83f1940bd91c867d9a (patch)
tree00c6c956c74a778cf98733d820f09f422a0f2765 /host/tests/CMakeLists.txt
parent87109484600083a6c74d6c5ae1c1a7e8398261b9 (diff)
downloaduhd-beb1f3c207bcf1ebc6ca1e83f1940bd91c867d9a.tar.gz
uhd-beb1f3c207bcf1ebc6ca1e83f1940bd91c867d9a.tar.bz2
uhd-beb1f3c207bcf1ebc6ca1e83f1940bd91c867d9a.zip
utils: Add scope_exit object
This is a utility for RAII-style operations. An object that will run code when a scope is left. Also includes unit tests.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 8a67e3f85..33fbcdbf9 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -39,6 +39,7 @@ set(test_sources
narrow_cast_test.cpp
property_test.cpp
ranges_test.cpp
+ scope_exit_test.cpp
sid_t_test.cpp
sensors_test.cpp
soft_reg_test.cpp