aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLane Kolbly <lane.kolbly@ni.com>2020-04-06 11:17:29 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-04-08 15:13:53 -0500
commitabf025f0a5c537f0b2ab07da933ffb82f62418ef (patch)
treebd877c33a6264794c2b92d96970d2984b25c7cba /host/tests/CMakeLists.txt
parentd398fe465724a3c2efb6abb1c720fc9f3a037701 (diff)
downloaduhd-abf025f0a5c537f0b2ab07da933ffb82f62418ef.tar.gz
uhd-abf025f0a5c537f0b2ab07da933ffb82f62418ef.tar.bz2
uhd-abf025f0a5c537f0b2ab07da933ffb82f62418ef.zip
uhd: Add fuzzy serial number checking
We have integer 32-bit serial numbers for MPM devices, for example "1234abcd". For serial numbers which have less than eight digits, e.g. "123abcd", a user may feel inclined to prefix this number with a 0 when they are searching for devices, e.g. "0123abcd". This change makes it so that specifying "0123abcd" will match a device with serial number "123ABCD".
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index f9f94e023..828729b79 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -269,6 +269,12 @@ UHD_ADD_NONAPI_TEST(
${CMAKE_SOURCE_DIR}/lib/transport/offload_io_service.cpp
)
+UHD_ADD_NONAPI_TEST(
+ TARGET "serial_number_test.cpp"
+ EXTRA_SOURCES
+ ${CMAKE_SOURCE_DIR}/lib/utils/serial_number.cpp
+)
+
########################################################################
# demo of a loadable module
########################################################################