aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-06-28 11:44:37 -0700
committerMartin Braun <martin.braun@ettus.com>2019-11-26 11:49:30 -0800
commita36fc4604f9b37c46fd203d6461d0d38065a97e9 (patch)
tree8f1687fceb7ffc05eaed91acc8d4c794a5e448f2 /host/tests/CMakeLists.txt
parentdbca54be2480a9ea1e84dd4b73349fd07fcaafe9 (diff)
downloaduhd-a36fc4604f9b37c46fd203d6461d0d38065a97e9.tar.gz
uhd-a36fc4604f9b37c46fd203d6461d0d38065a97e9.tar.bz2
uhd-a36fc4604f9b37c46fd203d6461d0d38065a97e9.zip
rfnoc: DDC: Fix property propagation
- Combine scaling and samp_rate resolvers - Prioritize decim when user has set it for DDC: When samp_rate_in changes, either the samp_rate_out or the decim values may change to accommodate it. If decim has been set by the user (which can be determined by the valid flag), prefer changing samp_rate_out over decim.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 1cdb42b96..0df2d810c 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -245,17 +245,25 @@ UHD_ADD_NONAPI_TEST(
${CMAKE_SOURCE_DIR}/lib/rfnoc/client_zero.cpp
)
+set_source_files_properties(
+ ${CMAKE_SOURCE_DIR}/lib/utils/system_time.cpp
+ PROPERTIES COMPILE_DEFINITIONS
+ "HAVE_MICROSEC_CLOCK"
+)
UHD_ADD_NONAPI_TEST(
TARGET rfnoc_blocks_test.cpp
EXTRA_SOURCES
${CMAKE_SOURCE_DIR}/lib/rfnoc/noc_block_base.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/block_id.cpp
${CMAKE_SOURCE_DIR}/lib/utils/compat_check.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/system_time.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/ddc_block_control.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/null_block_control.cpp
- ${CMAKE_SOURCE_DIR}/lib/rfnoc/radio_control_impl.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/register_iface_holder.cpp
${CMAKE_SOURCE_DIR}/lib/usrp/cores/dsp_core_utils.cpp
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/graph.cpp
+ INCLUDE_DIRS
+ ${CMAKE_BINARY_DIR}/lib/ic_reg_maps/
)
UHD_ADD_NONAPI_TEST(