aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Williams <alex.williams@ni.com>2019-11-04 16:20:59 -0800
committerMartin Braun <martin.braun@ettus.com>2019-11-26 12:21:33 -0800
commit80ec3fee4298d5b0defd98db7dcf1a01f49e9778 (patch)
treeebb2cd2463588f2e69d494b47dcc9b3b2f5b14b3 /host/tests/CMakeLists.txt
parentf5861562d9fde84d73c381aa51753602a75546f2 (diff)
downloaduhd-80ec3fee4298d5b0defd98db7dcf1a01f49e9778.tar.gz
uhd-80ec3fee4298d5b0defd98db7dcf1a01f49e9778.tar.bz2
uhd-80ec3fee4298d5b0defd98db7dcf1a01f49e9778.zip
lib,tests: Remove old DPDK files from build
The DPDK files are left behind as a reference, for now.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 89d0926fa..4578a6307 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -115,25 +115,6 @@ endmacro(UHD_ADD_NONAPI_TEST)
###############################################################################
# Now add all unit tests that require special linkage
###############################################################################
-if(ENABLE_DPDK)
- find_package(DPDK)
- UHD_ADD_NONAPI_TEST(
- TARGET "dpdk_test.cpp"
- EXTRA_SOURCES
- ${CMAKE_SOURCE_DIR}/lib/utils/config_parser.cpp
- ${CMAKE_SOURCE_DIR}/lib/utils/paths.cpp
- ${CMAKE_SOURCE_DIR}/lib/utils/pathslib.cpp
- ${CMAKE_SOURCE_DIR}/lib/utils/prefs.cpp
- ${CMAKE_SOURCE_DIR}/lib/transport/dpdk_zero_copy.cpp
- INCLUDE_DIRS
- ${DPDK_INCLUDE_DIR}
- ${CMAKE_BINARY_DIR}/lib/transport/
- ${CMAKE_SOURCE_DIR}/lib/transport/
- EXTRA_LIBS ${DPDK_LIBRARIES}
- NOAUTORUN # Don't register for auto-run, it requires special config
- )
-ENDIF(ENABLE_DPDK)
-
UHD_ADD_NONAPI_TEST(
TARGET "system_time_test.cpp"
EXTRA_SOURCES