aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authormattprost <matt.prost@ni.com>2020-03-19 16:09:20 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-04-02 12:12:26 -0500
commit6aed4b5a45cf0057bc175e19a86888259bf17cec (patch)
treed92b825a039345957385d6d0f689dc5f4adb3c91 /host/tests/CMakeLists.txt
parent7ad64600fe3db643ba10a88990263b13dac7d063 (diff)
downloaduhd-6aed4b5a45cf0057bc175e19a86888259bf17cec.tar.gz
uhd-6aed4b5a45cf0057bc175e19a86888259bf17cec.tar.bz2
uhd-6aed4b5a45cf0057bc175e19a86888259bf17cec.zip
rfnoc: Add multichannel register interface
This utility class implements the register access methods of reg_iface but adds built-in address translation features for consecutive instances of an RFNoC block. The register peek and poke methods accept an extra 'instance' parameter which is used to calculate the absolute address for the register access. This can be used for accessing registers for the different channels of a multi-channel block (i.e. Radio, DDC, DUC, etc). Signed-off-by: mattprost <matt.prost@ni.com>
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 2742c0385..3665a9d17 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -59,6 +59,7 @@ set(test_sources
tx_streamer_test.cpp
block_id_test.cpp
rfnoc_property_test.cpp
+ multichan_register_iface_test.cpp
)
#turn each test cpp file into an executable with an int main() function