aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2017-11-10 21:43:09 -0800
committerMartin Braun <martin.braun@ettus.com>2018-02-01 06:35:37 +0100
commit4ebfea45f32cc845d7887e552e8c6084d8ef3067 (patch)
tree03072dbab4870b9d648d154331d0ee7911da1b24 /host/tests/CMakeLists.txt
parent21be43d40a0fe33af9597e77fb3465caa7079033 (diff)
downloaduhd-4ebfea45f32cc845d7887e552e8c6084d8ef3067.tar.gz
uhd-4ebfea45f32cc845d7887e552e8c6084d8ef3067.tar.bz2
uhd-4ebfea45f32cc845d7887e552e8c6084d8ef3067.zip
lib: Add config_parser class
This class is not publicly exported. It is meant to read config files in the INI format. Reviewed-by: Brent Stapleton <brent.stapleton@ettus.com>
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 0741191f2..b22f5722c 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -111,6 +111,19 @@ TARGET_LINK_LIBRARIES(nocscript_parser_test uhd ${Boost_LIBRARIES})
UHD_ADD_TEST(nocscript_parser_test nocscript_parser_test)
UHD_INSTALL(TARGETS nocscript_parser_test RUNTIME DESTINATION ${PKG_LIB_DIR}/tests COMPONENT tests)
+ADD_EXECUTABLE(config_parser_test
+ config_parser_test.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/config_parser.cpp
+)
+TARGET_LINK_LIBRARIES(config_parser_test uhd ${Boost_LIBRARIES})
+UHD_ADD_TEST(config_parser_test config_parser_test)
+UHD_INSTALL(TARGETS
+ config_parser_test
+ RUNTIME
+ DESTINATION ${PKG_LIB_DIR}/tests
+ COMPONENT tests
+)
+
########################################################################
# demo of a loadable module
########################################################################