aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuel O'Brien <sam.obrien@ni.com>2020-06-23 15:09:55 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-07-13 15:21:52 -0500
commit297d5855ca3ac2e3fea329bd938cf4763fac583b (patch)
treee302783f5efcadbd451d8d24463baece7d85a47c /host/tests/CMakeLists.txt
parent22837edfe20feb57c24f2a55edbb65757b3fab6a (diff)
downloaduhd-297d5855ca3ac2e3fea329bd938cf4763fac583b.tar.gz
uhd-297d5855ca3ac2e3fea329bd938cf4763fac583b.tar.bz2
uhd-297d5855ca3ac2e3fea329bd938cf4763fac583b.zip
utils: Expose CHDR Parsing API
This commit introduces a new public api in uhd::utils which allows serializing and deserializing chdr packets. As far as testing, this commit adds the chdr_parse_test test. It uses a wireshark trace located in rfnoc_packets_*.cpp as well as hand coded packets from hardcoded_packets.cpp to test the serialization and deserialization process Signed-off-by: Samuel O'Brien <sam.obrien@ni.com>
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 78e4d3539..a304c9783 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -28,6 +28,7 @@ set(test_sources
cal_database_test.cpp
cal_data_iq_test.cpp
cal_data_gain_pwr_test.cpp
+ chdr_parse_test.cpp
chdr_test.cpp
constrained_device_args_test.cpp
convert_test.cpp
@@ -203,7 +204,6 @@ UHD_ADD_NONAPI_TEST(
TARGET "streamer_benchmark.cpp"
EXTRA_SOURCES
${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr_packet_writer.cpp
- ${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr_types.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr_ctrl_xport.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr_rx_data_xport.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr_tx_data_xport.cpp
@@ -259,7 +259,6 @@ UHD_ADD_NONAPI_TEST(
UHD_ADD_NONAPI_TEST(
TARGET rfnoc_chdr_test.cpp
EXTRA_SOURCES
- ${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr_types.cpp
${CMAKE_SOURCE_DIR}/lib/rfnoc/chdr_packet_writer.cpp
INCLUDE_DIRS
${CMAKE_BINARY_DIR}/lib/rfnoc/