aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Williams <alex.williams@ni.com>2019-05-28 14:55:29 -0700
committerMartin Braun <martin.braun@ettus.com>2019-11-26 11:49:19 -0800
commit110527f96b8c83de47d25cdf14474e7eeba5fedb (patch)
tree761b4d7f59884281b7baac96f760128cc450b7ed /host/tests/CMakeLists.txt
parent4ff9b6d6a23ef901734a825c7d30dae0a9564b23 (diff)
downloaduhd-110527f96b8c83de47d25cdf14474e7eeba5fedb.tar.gz
uhd-110527f96b8c83de47d25cdf14474e7eeba5fedb.tar.bz2
uhd-110527f96b8c83de47d25cdf14474e7eeba5fedb.zip
transport: Implement a single-threaded I/O service
The inline_io_service connects transports to links without any worker threads. Send operations go directly to the link, and recv will perform the I/O as part of the get_recv_buffer() call. The inline_io_service also supports muxed links natively. The receive mux is entirely inline. There is no separate thread for the inline_io_service, and that continues here. A queue is created for each client of the mux, and packets are processed as they come in. If a packet is to go up to a different client, the packet is queued up for later. When that client attempts to recv(), the queue is checked first, and the attempts to receive from the link happen ONLY if no packet was found. Also add mock transport to test I/O service APIs. Tests I/O service construction and some basic packet transmision. One case will also uses a single link that is shared between the send and recv transports. That link is muxed between two compatible but different transports.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 431c380c3..0c48ae058 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -252,6 +252,12 @@ UHD_ADD_NONAPI_TEST(
${CMAKE_SOURCE_DIR}/lib/usrp/cores/dsp_core_utils.cpp
)
+UHD_ADD_NONAPI_TEST(
+ TARGET "transport_test.cpp"
+ EXTRA_SOURCES
+ ${CMAKE_SOURCE_DIR}/lib/transport/inline_io_service.cpp
+)
+
########################################################################
# demo of a loadable module
########################################################################