aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-11-27 21:36:46 -0800
committeratrnati <54334261+atrnati@users.noreply.github.com>2020-01-29 08:57:25 -0600
commit0a49a8844a65698b11fe979441a97939dad80044 (patch)
tree30bbd6fb82c17abf7db4627250f3586a8d6fb175 /host/tests/CMakeLists.txt
parent25b434ae858dd476e13738e0acaa9edeb019cee4 (diff)
downloaduhd-0a49a8844a65698b11fe979441a97939dad80044.tar.gz
uhd-0a49a8844a65698b11fe979441a97939dad80044.tar.bz2
uhd-0a49a8844a65698b11fe979441a97939dad80044.zip
rfnoc: Create mock factory
This is an API that allows creating mock block controllers, to write unit tests for block controllers. See rfnoc_blocks_test for an example how to use them.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 017778fb8..bf47f6638 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -245,7 +245,6 @@ UHD_ADD_NONAPI_TEST(
TARGET rfnoc_blocks_test.cpp
EXTRA_SOURCES
${CMAKE_SOURCE_DIR}/lib/rfnoc/graph.cpp
- ${CMAKE_SOURCE_DIR}/lib/rfnoc/registry_factory.cpp
)
UHD_ADD_NONAPI_TEST(