aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-02-16 18:21:44 -0800
committerMartin Braun <martin.braun@ettus.com>2018-02-20 16:23:46 -0800
commita99e89a689490aa03e2bbd8153b61e394cd55a6e (patch)
treedb28c00c4d5b44bba918eb4fc52a6683e52fa181 /host/tests/CMakeLists.txt
parent2ff296c99760628c4b0042cf6d2b32a0e3986364 (diff)
downloaduhd-a99e89a689490aa03e2bbd8153b61e394cd55a6e.tar.gz
uhd-a99e89a689490aa03e2bbd8153b61e394cd55a6e.tar.bz2
uhd-a99e89a689490aa03e2bbd8153b61e394cd55a6e.zip
lib: Add path_expandvars() internal API call
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 437a697d0..7d53b50c4 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -125,6 +125,29 @@ UHD_INSTALL(TARGETS
COMPONENT tests
)
+ADD_EXECUTABLE(paths_test
+ paths_test.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/pathslib.cpp
+)
+# Careful: This is to satisfy the out-of-library build of paths.cpp. This is
+# duplicate code from lib/utils/CMakeLists.txt, and it's been simplified.
+SET(UHD_LIB_DIR "lib")
+FILE(TO_NATIVE_PATH "${CMAKE_INSTALL_PREFIX}" UHD_PKG_PATH)
+STRING(REPLACE "\\" "\\\\" UHD_PKG_PATH "${UHD_PKG_PATH}")
+SET_SOURCE_FILES_PROPERTIES(
+ ${CMAKE_SOURCE_DIR}/lib/utils/paths.cpp
+ PROPERTIES COMPILE_DEFINITIONS
+ "UHD_PKG_PATH=\"${UHD_PKG_PATH}\";UHD_LIB_DIR=\"${UHD_LIB_DIR}\""
+)
+TARGET_LINK_LIBRARIES(paths_test uhd ${Boost_LIBRARIES})
+UHD_ADD_TEST(paths_test paths_test)
+UHD_INSTALL(TARGETS
+ paths_test
+ RUNTIME
+ DESTINATION ${PKG_LIB_DIR}/tests
+ COMPONENT tests
+)
+
########################################################################
# demo of a loadable module
########################################################################