aboutsummaryrefslogtreecommitdiffstats
path: root/host/test/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Foster <nick@nerdnetworks.org>2010-10-21 11:18:56 -0700
committerNick Foster <nick@nerdnetworks.org>2010-10-21 11:18:56 -0700
commit53412938fe7c851591026ef4c25233806f4f27a3 (patch)
tree0824ac4bab6ff987436093239388c8038a8125a5 /host/test/CMakeLists.txt
parent2f6ab109231667ee255d2ba7cba34a0519019dc9 (diff)
parente2f76bddae7845024056b479658651c6da2b0f4d (diff)
downloaduhd-53412938fe7c851591026ef4c25233806f4f27a3.tar.gz
uhd-53412938fe7c851591026ef4c25233806f4f27a3.tar.bz2
uhd-53412938fe7c851591026ef4c25233806f4f27a3.zip
Merge branch 'master' of ettus.sourcerepo.com:ettus/uhdpriv into usrp2p
Conflicts: host/lib/usrp/CMakeLists.txt
Diffstat (limited to 'host/test/CMakeLists.txt')
-rw-r--r--host/test/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/host/test/CMakeLists.txt b/host/test/CMakeLists.txt
index c620fd641..d67399e5b 100644
--- a/host/test/CMakeLists.txt
+++ b/host/test/CMakeLists.txt
@@ -18,8 +18,7 @@
########################################################################
# unit test suite
########################################################################
-ADD_EXECUTABLE(main_test
- main_test.cpp
+SET(test_sources
addr_test.cpp
buffer_test.cpp
byteswap_test.cpp
@@ -28,13 +27,24 @@ ADD_EXECUTABLE(main_test
error_test.cpp
gain_group_test.cpp
subdev_spec_test.cpp
+ time_spec_test.cpp
tune_helper_test.cpp
vrt_test.cpp
warning_test.cpp
wax_test.cpp
)
-TARGET_LINK_LIBRARIES(main_test uhd)
-ADD_TEST(test main_test)
+
+#turn each test cpp file into an executable with an int main() function
+ADD_DEFINITIONS(-DBOOST_TEST_DYN_LINK -DBOOST_TEST_MAIN)
+
+#for each source: build an executable, register it as a test, and install
+FOREACH(test_source ${test_sources})
+ GET_FILENAME_COMPONENT(test_name ${test_source} NAME_WE)
+ ADD_EXECUTABLE(${test_name} ${test_source})
+ TARGET_LINK_LIBRARIES(${test_name} uhd)
+ ADD_TEST(${test_name} ${test_name})
+ INSTALL(TARGETS ${test_name} RUNTIME DESTINATION ${PKG_DATA_DIR}/tests)
+ENDFOREACH(test_source)
########################################################################
# demo of a loadable module