aboutsummaryrefslogtreecommitdiffstats
path: root/host/python/CMakeLists.txt
diff options
context:
space:
mode:
authorBrent Stapleton <brent.stapleton@ettus.com>2019-11-18 14:06:39 +0530
committerBrent Stapleton <brent.stapleton@ettus.com>2020-01-02 15:38:56 -0800
commit400b00c34338af502c5d786edcfb8512bfbbff8b (patch)
tree9974e0ea352e1879f6381091103fab84637b441c /host/python/CMakeLists.txt
parent2b8cae59a70d1f19a9350aa9c824008ceea5cb70 (diff)
downloaduhd-400b00c34338af502c5d786edcfb8512bfbbff8b.tar.gz
uhd-400b00c34338af502c5d786edcfb8512bfbbff8b.tar.bz2
uhd-400b00c34338af502c5d786edcfb8512bfbbff8b.zip
rfnoc: adding RFNoC Python API
Adding Python bindings for the RFNoC API. This includes the rfnoc_graph, noc_block_base, and several other supporting classes. Templated functions are not currently supported. For example, `rfnoc_graph::get_block` can only return the basic block controller.
Diffstat (limited to 'host/python/CMakeLists.txt')
-rw-r--r--host/python/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/python/CMakeLists.txt b/host/python/CMakeLists.txt
index 5598dda24..2b2a35d2e 100644
--- a/host/python/CMakeLists.txt
+++ b/host/python/CMakeLists.txt
@@ -52,6 +52,7 @@ set(PYUHD_FILES
${CMAKE_CURRENT_SOURCE_DIR}/types.py
${CMAKE_CURRENT_SOURCE_DIR}/usrp.py
${CMAKE_CURRENT_SOURCE_DIR}/filters.py
+ ${CMAKE_CURRENT_SOURCE_DIR}/rfnoc.py
)
set(SETUP_PY_IN "${CMAKE_CURRENT_SOURCE_DIR}/setup.py.in")